• 0
Sign in to follow this  
Followers 0

Truma Ultraheat


Question

Posted

Hi,

I wonder if anyone has come across this problem. I have an Eldis Vogue 524, 2003, which has always worked well. However last week, a particularly wet one on Loch Lomond, we needed to put the heater on to take the chill off. It started to heat up but then as it got warm, the MCB tripped taking off all the electrics. This was on the 2K setting, and was always repeated on the other 2 settings. It works well on gas.

Any ideas ?

Share this post


Link to post
Share on other sites

3 answers to this question

  • 0

Posted

The Elddis group vans around this year were often fitted with Chinese MCB,s that were prone to tripping prematurely, our friends had the same problem on theirs changed MCB and it was fine.

Share this post


Link to post
Share on other sites
  • 0

Posted

Thanks for that, I'll try changing it, though it seems strange that it's been ok for so long.

My next attempt at the solution.

 

Share this post


Link to post
Share on other sites
  • 0

Posted

Sounds like one of the Elements in the heater has an earth fault. I take it that it was the RCD that tripped not the smaller 10 amp mcb

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0


Click this banner for a Motorhome and Touring Caravan insurance quote from Caravan Guard