• 0
Sign in to follow this  
Followers 0

Good old Utube

Question

Posted

We arrived in France to find that the flush on our toilet not working, odd because I did check everything before we left. Any way not the end of the world. I had a look and found a blown fuse, replaced it but still no go, A bit stumped now so I googled it and up came a Utube "How to" vid. Basically from inside you access the tank pull out the pump and in the bottom is a small impeller that gets gunked up with the pink fluid, give it a few gentle twist and voila off it goes and its still going. Thank You Utube.

Share this post


Link to post
Share on other sites

1 answer to this question

  • 0

Posted

Hi Dillon...we had the exact same problem many years ago..The "pink stuff" does seem to clog the flush pump thru time..My solution is we never use the stuff,we just use ordinary pine disinfectant and we have never had a problem since..We have changed 'vans 3 times since then and have flushed out each flush tank with warm water and soda crystals 'till the water runs clear and all the wee black bits have gone..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0


Click this banner for a Motorhome and Touring Caravan insurance quote from Caravan Guard